
1 

 

 

 

 

 

 

 

 
 

Chapter 1 

Introduction to MS Excel 
 

Microsoft (MS) Excel is a spreadsheet application developed by Microsoft. Excel 

is one of the most widely used spreadsheet application and it is part of Microsoft 

Office suite. A spreadsheet is basically a matrix of rows and columns. It is useful 

in entering, analyzing, editing and storing data. Using Excel, you can perform 

arithmetic operations with numerical data such as addition, subtraction, 

multiplication and division. Also you can sort numbers and use simple financial, 

mathematical and statistical formulas. To display numbers graphically, you can 

use Excel to create a chart. In this book, we are using MS Office suite version 

2007 to explain Excel, PowePoint and Picture Manager and all the given figures 

and examples are accordingly.  

 

STARTING EXCEL 

You start Excel in the same way that you start every application in Microsoft 

Office Suite like Word, PowerPoint, Access etc. You can start Excel from the start 

menu as follows: 

Step 1: Click on the Start button on the task bar at the bottom-left corner of the 

screen 

Step 2: Click on All Programs option from the menu 

Step 3: Select Microsoft Office from the list of programs 

Step 4: Click on Microsoft Office Excel 2007 
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This will launch the MS Excel 2007 application and the following excel window 

will be shown. 
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1.1 COMPARISON BETWEEN MS-WORD AND MS-EXCEL 

Microsoft Excel and Microsoft Word are two application software programs in the 

Microsoft Office suite. Though they are made to work together, they each have 

different strengths. Word is first and foremost a word processor, while Excel is 

primarily for numeric calculations. Excel is a spreadsheet program that is used to 

record and analyze numerical data. Word, on the other hand, is word processing 

application that is used to write documents like letters or essays where text 

formatting is very essential to provide a printable document that can be read very 

easily.  

 

You can insert tables in a Word document or write whole paragraphs inside a 

single Excel cell and both applications can create printable documents. Therefore, 

it is possible to use one to simulate the function of the other to some extent. But 

each application has strengths that make them well suited to the tasks they 

perform. The font, paragraph, and page formatting options of Word makes it easy 

to create documents, which is quite difficult in Excel. Whereas Excel has ability to 

analyze, compute formulas and conditional statements. This can be as simple as 

the sum of all the entered data, taking their average, to even more complex 

equations. You would not find this type of capability within Word. 

 

Table 1: Comparison between MS-Word and MS-Excel 

S. 

No. 

MS-Word MS-Excel 

1 Word processing application Spreadsheet application 

2 Use for writing letters, essays  Use to create tabulated documents 

3 Use where text formatting is 

essential 

Use to record and analyze numerical 

data 

4 Excel tables can be inserted inside 

a Word document 

Word document can not be inserted 

inside a Excel table 

5 Have advanced formatting 

facilities 

Does not have advanced formatting 

facilities 

6 Cannot write custom equations 

and formulas 

Can write custom equations and 

formulas 

 

1.2 WORKSHEETS AND WORKBOOKS 

When you start Excel, you will automatically start in a new, blank workbook. An 

ordinary Excel file is called a “Workbook” that can contain different things such 

as worksheets, chart sheets and small programs. Each workbook can hold one or 

more worksheets. An Excel worksheet is a single spreadsheet that contains matrix 
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of rows (designated by numbers) and columns (designated by letters). The 

intersection of a row and a column is called a cell. Each cell has a cell address that 

is the column letter and the row number. Each cell can contain number, text or 

formula. A cell can also reference another cell in the same worksheet, the same 

workbook or a different workbook. The worksheets in a workbook are accessible 

by clicking the worksheet tabs, just above the status bar. By default, Excel 

provides three worksheets in a workbook with name as Sheet1, Sheet2, 

and Sheet3. You can insert additional worksheets or delete them as needed. You 

can also change the number of worksheets that appear by default in a new 

workbook. 

 

1.3 CREATING A WORKBOOK 

If you’re working in MS Excel 2007 and want to begin work in a new Excel file, 

you can create a new workbook using following steps: 

Step 1: Click the Office button 

Step 2: Choose New 

Step 3: Click the Blank Workbook icon 

Step 4: Click the Create button 
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1.4 OPENING 

To open an existing workbook, you can use following steps: 

Step 1: Click on the Office button and then click Open  

  Alternatively, use Open command (Ctrl + O) 

Step 2: In the Open dialog box, locate and double-click the workbook file that 

you want to open 
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Alternatively you can go to window explorer and find out the file you want to 

open and double click on it. 

 

1.5 LABELING 

The letters and numbers of the columns and rows headings called labels, are 

displayed in gray boxes across the top and left side of the worksheet. Column 

headings are labelled with alphabetic characters, beginning with column A. 

Rows headings are labelled with numbers, beginning with row 1. Generally a 

workbook is labeled by three worksheets as Sheet1, Sheet2, and Sheet3. You 

can change the labeling of worksheets using renaming, inserting new sheets, 

deleting sheets and merging sheets etc. 

 

1.6 FORMAT WORKBOOK TABS 

When you open a new workbook, or add new worksheets to an existing 

workbook, Excel uses a generic name as Sheet1, Sheet2, Sheet3, and so on for 

each sheet. As you build out a workbook, you'll probably need to rename these 

sheets to keep things organized. The easiest way to rename a worksheet is to 

double click its name. This will highlight the text of the name, and you can then 

type a new name. You can also right click on a worksheet and choose Rename 

from the pop-up menu. There are a few rules to keep in mind when you rename 

tabs. Excel worksheet names have to be at least one character long, and can't be 

longer than 31 characters. Also you can't have two sheets with same name in the 
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same workbook. Some characters are not allowed in worksheet names, such as 

question marks, square brackets, asterisks, apostrophes, forward and backward 

slashes, periods and colons. You can also change the color of a worksheet tab. To 

change the color, right click and choose tab color from the menu, then choose a 

color of your choice. 

 

 
 

1.7 REPOSITION SHEETS 

It's easy to move or copy a whole worksheet to another location in a workbook. 

The calculations or charts data might become inaccurate during move of 

worksheet. To reposition the sheet use following steps: 

Step 1: Select the worksheets that you want to move or copy 

Step 2: On the Home tab, in the Cells group, click Format, and then 

under Organize Sheets, click Move or Copy Sheet 

Alternatively, you can right click and select Move or Copy from pop-up 

menu 

Step 3: In the Move or Copy dialog box, in the Before sheet list, do one of the 

following: 

� Click the sheet before which you want to insert the moved or 

copied sheets 

� Click move to end to insert the moved or copied sheets after the 

last sheet in the workbook and before the Insert Worksheet tab 

Step 4: To copy the sheets instead of moving them, in the Move or Copy dialog 

box, select the Create a copy check box 
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When you create a copy of the worksheet, the worksheet is duplicated in the 

workbook, and the sheet name indicates that it is a copy. For example, the first 

copy that you make of Sheet1 is named Sheet1 (2). We can also move or copy 

worksheets to another workbook. For this, we need to make sure that the target 

workbook is open in the same instance of MS Excel. All other steps are similar as 

above except in the Move or Copy dialog box, from To book list, select the 

workbook to which you want to move or copy the selected sheets. 

 

1.8 NAMING 

To name (or rename) a worksheet use following steps: 

Step 1: Right click on the worksheet tab which you want to rename  

Step 2: select Rename from the pop-up menu 

Step 3: Type new name and press ENTER (Anil in our example) 
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1.9 ADDING 

To add a new worksheet at the end of the existing worksheets, click the Insert 

Worksheet tab at the bottom of the screen. To insert a new worksheet before an 

existing worksheet use following steps: 

Step 1: Right click on the worksheet tab before which you want to add a new 

worksheet 

Step 2: select Insert from the pop-up menu 

 

         
 

Another way to insert a new worksheet before an existing worksheet: 

Step 1: Select the worksheet tab before which you want to add a new worksheet 

Step 2: Select Home tab 

Step 3: Click Insert in Cells group 

Step 4: Click on Insert Sheet 
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1.10 DELETING 

To delete a worksheet, right click on the worksheet tab at the bottom of the screen 

which you want to delete and select Delete from the pop-up menu. 

 

       
 

Another way to delete a worksheet: 

Step 1: Select the worksheet tab which you want to delete 

Step 2: Select Home tab 

Step 2: Click Delete in Cells group 

Step 3: Click on Delete Sheet 

 

 
 

1.11 HIDING  

To hide a worksheet, right click on the worksheet tab at the bottom of the screen 

which you want to hide and select Hide from the pop-up menu. 
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Another way to hide a worksheet: 

Step 1: Select the worksheet tab which you want to hide 

Step 2: Select Home tab 

Step 3: Click Format in Cells group 

Step 4: Under Visibility, go to Hide & Unhide option, and then click Hide Sheet 

 

 
 

1.12 UNHIDING 

To unhide the hidden worksheet, use following steps: 

Step 1: Right click on the worksheet tab  

Step 2: Select Unhide from the pop-up menu  

Step 3: Choose the worksheets you want to unhide from the list and click ok 

 

Another way to Unhide a worksheet: 

Step 1: Select the worksheet tab  

Step 2: Select Home tab 

Step 3: Click Format in Cells group         

Step 4: Under Visibility, go to Hide & Unhide, and then click Unhide Sheet 

Step 5: Choose the worksheets you want to unhide from the list and click ok 
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1.13 SAVING WORKBOOKS AND WORKSHEETS 

You can save a workbook for the first time by using following steps: 

Step 1: Click on the Office button and then click Save  

Step 2: In the Dialog Box select the location where you want to save the file 

Step 3: Type the file name 

Step 4: Click on Save 

 

Alternatively a workbook can be saved by clicking on the Save icon at the top left 

corner or by using command (Ctrl + S). 
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To close a workbook, click on the Office button and then click Close.  

 

 
 

1.14 NAVIGATING MS EXCEL 

Navigating around an Excel document with a lot of worksheets can be difficult. 

Navigation buttons can be use to quickly jump to a different worksheet in the 

current workbook.  In the bottom-left corner of the Excel workbook, you’ll see 

four navigation buttons to the left of the worksheet tabs.  
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Right-clicking on these buttons will display a list of all the worksheets, identified 

by name, in the current workbook. Selecting a name in this list will take you to 

that worksheet. Following are the shortcut keys to navigate the workbook: 

� Ctrl + Page Down: Move to the next sheet in the workbook 

� Ctrl + Page Up: Move to the previous sheet in the workbook  

� Ctrl + F6/Tab: Move to the next workbook window 

� Ctrl + Shift + F6/Tab: Move to the previous workbook window 

� F6/ Shift + F6: Move to the next/previous worksheet-pane in a worksheet 

that has been split 

 

1.15 INSERT CELLS, ROWS AND COLUMNS 

Insert blank cells in a worksheet 

Select the cell where you want to insert the new blank cell and use following 

steps: 

Step 1: On the Home tab, in the Cells group, click Insert 

Step 2: Click Insert Cells 

You can perform the same operation through right-click on the selected 

cell and then click Insert. 

Step 3: In the Insert dialog box, choose appropriate option 
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To insert more than one cell, select multiple cells in the worksheet, where you 

want to insert the new blank cells and follow the same steps. For example, to 

insert four blank cells, you need to select four cells. 

 

Insert blank Rows in a worksheet 

Step 1:  

• To insert a single row, select the row or a cell in the row above 

which you want to insert the new blank row 

• To insert more than one row, select the rows above which you 

want to insert the new blank rows (Inorder to insert nonadjacent 

rows, hold down Ctrl while you select nonadjacent rows) 

Step 2: On the Home tab, in the Cells group, click Insert 

Step 3: Click Insert Sheet Rows 

 

You can perform the same operation through right-click on the selected row(s) 

and then click Insert. 

 

 
 

Insert blank Columns in a worksheet 

Step 1:  

• To insert a single column, select the column or a cell in the column 

immediately to right of where you want to insert the new blank 

column 
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• To insert more than one column, select the columns immediately to 

right of where you want to insert the new blank columns (Inorder 

to insert nonadjacent columns, hold down Ctrl while you select 

nonadjacent columns) 

Step 2: On the Home tab, in the Cells group, click Insert 

Step 3: Click Insert Sheet Columns 

 

You can perform the same operation through right-click on the selected column(s) 

and then click Insert. 

 

 
 

1.16 DELETE CELLS, ROWS OR COLUMNS 

Select the cells, rows, columns that you want to delete and use following steps: 

Step 1: On the Home tab, in the Cells group, click Delete 

Step 2:  

• To delete selected cells, click Delete Cells 

• To delete selected rows, click Delete Sheet Rows 

• To delete selected columns, click Delete Sheet Columns 

Step 3: In the Delete dialog box, choose appropriate option 
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You can perform the same operation through right-click on the selected cells, 

rows, columns and then click Delete. 

 

1.17 MERGE 

A cell merge converts selected cells into a single cell. This can be useful for 

creating titles. You can combine or merge text from two or more cells into 

one cell. Use the following steps to perform merge operation: 

Step 1: Select the cells you want to merge 

Step 2: Got to Alignment group of Home tab 

Step 3: Click Merge & Center  

There are four options: 

• Merge & Center 

• Merge Across 

• Merge Cells 

• Unmerge Cells 

Step 4: Click appropriate option 
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1.18 SPLITTING 

After merging cells, you can split a merged cell into separate cells again. You 

cannot split an unmerged cell. Use the following steps to perform split operation: 

Step 1: Select the cells you want to split 

Step 2: Got to Alignment group of Home tab 

Step 3: Click Merge & Center  

Step 4: Click Unmerge Cells option 
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1.19 HIDING COLUMN(S) AND ROW(S) 

Hiding column(s) or row(s) will help you to prevent unwanted changes in your 

workbook. To hide a column/row, use following steps: 

Step 1: Select the column/row that you want to hide by clicking on their header 

Step 2: On the Home tab, in the Cells group, click Format 

Step 3: Under Visibility, point to Hide & Unhide, and then click Hide Columns/ 

Hide Rows  
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You can perform the same operation through right-click on the selected 

column(s)/row(s) header(s) and then click Hide. 

 

1.20 UNHIDING COLUMN(S) AND ROW(S) 

To unhide the hidden column(s)/row(s), perform following step: 

Step 1: Select the columns/rows, adjacent to either side of the column(s)/row(s) 

that you want to unhide 

Step 2: On the Home tab, in the Cells group, click Format 

Step 3: Under Visibility, point to Hide & Unhide, and then click Unhide 

Columns/Unhide Rows 
 

You can perform the same operation through right-click on the selected 

column(s)/row(s) header(s) and then click Unhide. 

 

1.21 FORMAT 

In Excel, every cell can be formatted differently. There are many options available 

to customize your Excel workbook, which can make the worksheet easier to read. 

Excel also provides many number formats, allowing you to standardize how 

numbers will appear in your document. Next chapter describes this topic in detail. 

To format cells use following steps: 

Step 1: Select the cells that you want to format 

Step 2: Right-click and then select Format Cells from the popup menu 

Step 3: Select appropriate option from Format Cells and click OK 
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1.22 FILTER AND SORT OF CELLS 

Sorting is a common spreadsheet task that allows you to easily reorder your data. 

The most common type of sorting is alphabetical ordering, which you can do in 

ascending or descending order. To sort in alphabetical order: 

Step 1: Select a cell in the column you want to sort  

Step 2: Click the Sort & Filter command in the Editing group of the Home tab 

Step 3: Select appropriate option 
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You filter data to displays only the rows that meet criteria that you specify and 

hides rows that you do not want displayed. After you filter data, you can copy, 

find, edit, format, chart, and print the subset of filtered data without rearranging or 

moving it. You can also filter by more than one column. Filters are additive, 

which means that each additional filter is based on the current filter and further 

reduces the subset of data.  

 

1.23 HEADERS AND FOOTERS  

Headers and footers can be useful tools for identifying and organizing a 

document. A header is a section of information that is printed above the body of 

the document, and a footer is a section of information that is printed below the 

body of the document. Information in headers and footers is often static 

throughout a document. For example, you might create a footer that has page 

numbers, the date and time, and the name of your file. You may choose to add a 

built-in header or footer to your document, or to create a custom header and 

footer. 

 

Headers and footers are only displayed in Page Layout view and on the printed 

pages. They are not displayed on the worksheet in Normal view. You can insert 

headers or footers in Page Layout view, or you can use Page Setup dialog box, if 

you want to insert headers or footers for more than one worksheet at the same 

time.  

 

To Add or change the header or footer text by using Page Layout view, use 

following steps: 

Step 1: Click the worksheet to which you want to add headers or footers, or that 

contains headers or footers that you want to change 

Step 2: On the Insert tab, in the Text group, click Header & Footer, Excel will 

display the worksheet in Page Layout view (You can also click Page 

Layout View on the status bar to display this view) 

Step 3: Do one of the following: 

• To add a header or footer, click the left, center, or right header or 

footer text box at the top or the bottom of the worksheet page 

• To change a header or footer, click the header or footer text box at 

the top or the bottom of the worksheet page respectively, and then 

select the text that you want to change 

Step 4: Type the text that you want  

Step 5: To close the headers or footers, click anywhere in the worksheet (To close 

the headers or footers without keeping the changes that you made, press 

ESC) 
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To Add or change the header or footer text by using Page Setup dialog box, use 

following steps: 

Step 1: Click the worksheet to which you want to add headers or footers, or that 

contains headers or footers that you want to change 

Step 2: On the Page Layout tab, in the Page Setup group, click the Dialog Box 

Launcher, next to Page Setup, the Page Setup dialog box will be 

displayed 

Step 3: On the Header/Footer tab, click Custom Header or Custom Footer 

Step 4: Click in the Left section, Center section, or Right section boxes, to 

insert the header or footer information that you want in that section 

Step 5: To add or change the header or footer text, type additional text or edit the 

existing text in the Left section, Center section, or Right section boxes 
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1.24 SET MARGINS FOR HEADERS AND FOOTERS 

If there are problems with the display of your header or footer, you can fix them 

by adjusting the margins. You can adjust the margins in two ways: using 

the mouse option or the page setup dialog box option. 

To adjust margins with the mouse use following steps: 

Step 1: From the Office Button, select Print and then click Print 

Preview (Document will be displayed in Print Preview mode) 

Step 2: In the Preview group, select Show Margins (Margin outline will appear) 
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Step 3: Using the mouse, click and drag the margin outlines to the desired 

position  

Step 4: Click Close Print Preview 

To adjust margins with the Page Setup Dialog Box use following steps: 

Step 1: From the Office Button menu, select Print and click Print Preview 

(Document will be displayed in Print Preview mode) 

Step 2: In the Print group, click Page Setup (the Page Setup dialog box will be 

displayed) 

Step 3: Select the Margins tab  

Step 4: In the Top, Left, Right, Bottom, Header, and/or Footer text boxes, type the 

preferred margin size or use the nudge buttons to adjust the margins 

Step 5: Click OK 

Step 6: Click Close Print Preview 

 

 
 

1.25 INFORMATION ABOUT PRINTING 

You can print entire or partial worksheets and workbooks, one at a time, or 

several at once. And if the data that you want to print is in a Microsoft Office 

Excel table, you can print just the Excel table. You can also print a workbook to a 

file instead of to a printer. To print a partial or entire worksheet or workbook use 

following steps: 

Step 1: Do one of the following: 

• To print a partial worksheet, click the worksheet, and then select 

the range of data that you want to print 
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• To print the entire worksheet, click the worksheet to activate it 

• To print a workbook, click any of its worksheets 

Step 2: Click Office button, and then click Print (or press Keyboard shortcut 

Ctrl+P), Print dialog box will be displayed 

Step 3: Under Print what section, select an option to print the selection, the 

active sheet or sheets, or the entire workbook 

Step 3: Under Copies section, you can specify the number of copies to print 
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1.26 SELECT PRINT AREA 

If you print a specific selection on the worksheet frequently, you can define a print 

area that includes just that selection. When you print the worksheet after defining 

a print area, only the print area will print. You can add cells to expand the print 

area as needed, and you can clear the print area to print the entire worksheet again. 

 

To set a print area: select the cells that you want to define as the print area, then 

on the Page Layout tab, in the Page Setup group, click Print Area, and then 

click Set Print Area. 

 

To add cells to an existing print area: select the cells that you want to add to the 

existing print area then on the Page Layout tab, in the Page Setup group, 

click Print Area, and then click Add to Print Area. 

 

To clear a print area: click anywhere on the worksheet for which you want to 

clear the print area then on the Page Layout tab, in the Page Setup group, 

click Clear Print Area. 

 

1.27 PRINT A RANGE OF PAGES 

You can print a range of pages, by using appropriate options in Print Range 

section of Print dialog box. The options available under Print Range section are as 

follows: 

1. All: When the All option is selected, all the pages in the current worksheet 

will print. 

2. Page(s):  

• To print a single page, enter its page number in both the From and 

To text boxes here or select these page numbers with the spinner 

buttons. 

• To print a range of pages, put the first page number in the From 

text box and the last page number in the To text box. 

 

1.28 ABOUT ENTERING INFORMATION INTO EXCEL 

To enter information in Excel, just select a cell and begin typing. You'll see the 

text appear both in the cell and in the formula bar above. To tell Excel to accept 

the information you've typed, press enter. The information will be entered 

immediately, and the cursor will move down one cell. You can also press the tab 

key instead of the enter key. If you press tab, the cursor will move one cell to the 

right once the information has been entered. At any time while you are typing you 

can press the escape key to cancel. This brings Excel back to the state it was in 



28 

 

before you started typing. When you want to delete information that has already 

been entered, just select the cells, and press the delete key. The information that 

you enter can be numbers, text, dates, or times. You can format the information in 

a variety of ways. And, there are several settings that you can adjust to make 

information entry easier for you. 

 

1.29 ENTERING DATA 

There are three types of data you enter in Excel: text, value (number), or 

formula. If Excel detects that the data you entry is a formula, it will calculate the 

formula and display the result in the cell. You can see the formula in the Formula 

Bar when the cell is active. If it detects that it's not a formula, Excel then decides 

if it's text or value. Text entries are aligned to the left side of the cell whereas 

values are aligned to the right. It is very important to know so you can make sure 

you are entering things correctly, and Excel is recognizing your entries as the 

correct data type. 

 

1.30 ENTERING LABELS 

A label most often refers to a text entry such as a heading used to identify 

a column of data. To enter label (i.e. text data) in excel, first select the cell in 

which data has to be entered and then type the text. Press ENTER key to finish 

your text entry. The text will be displayed in the active cell as well as in the 

Formula bar. Text entries are simply data that Excel can't classify as a formula or 

value. If you have numbers to be treated as text use an apostrophe (‘) as the first 

character. You cannot do calculations with these kind of data entry. You can 

always check if Excel is classifying your entry as text because text will be aligned 

to the left side of the cell. 

 

1.31 ENTERING VALUES 

Values are numbers that represent quantities, and can be used in mathematical 

calculations. To enter value in excel, first select the cell to make it an active cell 

and then type the value. Values are aligned to the right side of the cell. Values are 

the building blocks of all formulas that you enter. Your numbers can be from the 

entire range of numeric values: whole numbers (example, 32), decimals (example, 

18.56) and scientific notation (example, 0.146E+3). Excel displays scientific 

notation automatically if you enter a number that is too long to be viewed in its 

entirety in a cell. You may also see number signs (# # # # #) when a cell entry is 

too long. Widening the column that contains the cell with the above signs will 

allow you to read the number. 
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1.32 MULTIPLE ENTRIES 

In Excel, you can enter the same data or text into multiple cells at once using 

following simple steps: 

Step 1: Select all the cells that you want to have the same text 

Step 2: Type the text you want 

Step 3: After typing the text, instead of pressing Enter, press Ctrl+Enter 

 

After completing the above steps, the text will automatically be entered into all 

selected cells. This technique can be very useful any time you have data that has 

the same prefix and just need to add something to the end of each cell. For 

example, the above steps can be use to enter "The Computer" in all the selected 

cells, as shown in the below figure. 
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1.33 COPYING & PASTING OF CELLS, ROWS AND COLUMNS 

When you move or copy cell(s), rows and columns, Excel moves or copies all 

data that they contain, including formulas and their resulting values, comments, 

cell formats, and hidden cells. You can also copy specific contents or attributes 

from the cells. For example, you can copy the resulting value of a formula without 

copying the formula itself, or you can copy only the formula. To move or copy 

selected cell(s), row(s) and column(s), you can use Cut command 

or Copy command or mouse. Cut command or Copy commands can be used as 

follows: 

Step 1: Select the cell(s), row(s) or column(s) that you want to move or copy 

Step 2: On the Home tab, in the Clipboard group, do one of the following: 

• To move them, click Cut or use keyboard shortcut Ctrl+X 

• To copy them, click Copy or keyboard shortcut Ctrl+C 

Step 3: Right-click a row or column below or to the right of where you want to 

move or copy your selection, and then do one of the following: 

• When you are moving them, click Insert Cut Cells 

• When you are copying them, click Insert Copied Cells 

 

Using the mouse, you can move or copy cell(s), row(s) and column(s) as follows: 

Step 1: Select the cell(s), row(s) or column(s) that you want to move or copy 

Step 2: Do one of the following: 

• To move them, point to the border of the selection, when the pointer 

becomes a move pointer, drag the them to another location 

• To copy them, hold down Ctrl while you point to the border of the 

selection, when the pointer becomes a copy pointer, drag the them to 

another location 

 

To copy specific contents or attributes from the cells, when you paste cells, click 

the arrow below Paste and choose specific options as follows:  

• To paste values only, click Paste Values 

• To paste cell formats only, click Paste Special, and then click Formats 

under Paste 

• To paste formulas only, click Formulas 

 

1.34 FILLING CELLS WITH A SERIES OF DATA  

Excel provides many ways to repeat information in many cells throughout a 

worksheet. The most convenient way to repeat information in contiguous cells is 

by using the Fill handle. If the first cell contains a formula, the formula will be 

repeated in the additional cells. If the first cell contains text, the text will be 
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repeated in the additional cells. Excel autofills dates, months, and other 

established patterns of non-numerical data. If Excel recognizes a pattern in the 

information you entered, the additional cells will contain the next item in the 

pattern. For example, if the first cell contains the day Sunday, Excel will fill the 

following cells with Monday, Tuesday, etc. 

 

To use the fill handle, you select the cells that you want to use as a basis for filling 

additional cells, and then drag the fill handle across or down the cells that you 

want to fill. After you drag the fill handle, the Auto Fill Options button appears so 

that you can change how the selection is filled. For example, you can choose to 

fill just cell formats by clicking Fill Formatting Only, or you can choose to fill just 

the contents of a cell by clicking Fill Without Formatting. 

 

           
 

1.35 EDITING CELL DATA 

Editing your Excel worksheet data is very easy. You can edit your data by any of 

the following ways:  

• Select the cell containing data to be edited, and Press F2, then Use 

Backspace key and erase the wrong entry (Retype the correct entry) 

• Select the cell and simply retype the correct entry 

• If you want only to clear the contents of the cell, select the cell and press 

Delete key 

• To bring back the previous entry, either click on Undo button on standard 

Toolbar or use keyboard shortcuts Ctrl+Z 
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1.36 FIND AND REPLACE 

Excel’s Find and Replace feature is a very powerful tool that allows you to rapidly 

change the content of your worksheets. Use Find and Replace to locate and 

optionally replace text or values in a worksheet. You can narrow the search results 

by specifying formatting to look for as well as other search options, including 

Match Case. To find or replace text and numbers on a worksheet use following 

steps: 

Step 1: In a worksheet, click any cell 

Step 2: On the Home tab, in the Editing group, click Find & Select 

Step 3: Do the following: 

• To find text or numbers, click Find 

• To find and replace text or numbers, click Replace 

Step 4: In the Find what box, type the text or numbers that you want to search for 

Step 5: Click Options to further define your search, and then do any of the 

following: 

• To search for data in a worksheet or in an entire workbook, in 

the Within box, select Sheet or Workbook 

• To search for data in specific rows or columns, in the Search box, 

click By Rows or By Columns 

• To search for data with specific details, in the Look in box, 

click Formulas, Values, or Comments 

• To search for case-sensitive data, select the Match case check box 

• To search for cells that contain just the characters that you typed, in 

the Find what box, select the Match entire cell contents check box 
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1.37 GO TO CELL DATA 

To move to a specific cell of the worksheet, you can use the Go To command. 

The Go To command is also useful when moving between ranges. You can use F5 

to display the Go To dialog box. You can use  go to command as follows: 

Step 1: In a worksheet, click any cell 
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Step 2: On the Home tab, in the Editing group, click Go To... or Press F5, (Go 

To dialog box appears) 

Step 3: In the Go to scroll box, select a range name, or In the Reference text box, 

type a cell location 

Step 4: For advanced Go To options, click SPECIAL, and select an appropriate 

option 

Step 5: Click ok 

 

 
 

  
 

1.38 LOCKING ROWS AND COLUMNS BY SPLTTING PANES 

AND FREEZING PANES 
Splitting or freezing panes allow you to hold sections of a worksheet in place so 

they are visible at all times whilst scrolling through the worksheet. This is 

especially useful for large worksheets because you can hold the column and row 
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headings in place whilst you scroll through your data. For example, if the first row 

in your spreadsheet contains headers, you might freeze that row to make sure that 

the column headers remain visible as you scroll down in your spreadsheet. To 

Freeze rows or columns use following steps: 

Step 1: Click the label of the row, below the row that should remain frozen at the 

top of the worksheet 

Step 2:  Click Freeze Panes in the Window Group of View Tab 

Step 3:  Do one of the following: 

• To lock one row only,  click Freeze Top Row 

• To lock one column only, click Freeze First Column 

• To lock more than one row or column, or to lock both rows and columns at 

the same time, click Freeze Panes (You will need your cursor to be below 

the row(s) you want to freeze and to the right of any column(s) you want 

to freeze) 

• To lock multiple rows (starting with row 1), select the row below the last 

row you want frozen, click Freeze Panes 

• To lock multiple columns, select the column to the right of the last column 

you want frozen, click Freeze Panes 

Step 4:  To remove the frozen panes, click Unfreeze Panes 

 

You can also split the worksheet window into separate panes and scroll the 

worksheet in each pane so that you can easily compare data from two separate 

worksheet locations. Splitting panes allows you to see multiple areas of a 

worksheet at once. To split a worksheet into panes use following steps: 

Step 1:  Select the cell where you want to split the worksheet (worksheet will be 

split above and to the left of the active cell creating four panes) 

Step 2:  Click the Split button in the Window group of View tab 

 

The worksheet will split into sections that can be navigated individually without 

moving the other sections. You can also click and drag the panes to adjust the 

location of the split. Click the Split button again to remove the split. 
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1.39 SPELL CHECK 

Excel includes a built-in spell checker that can find and get rid of spelling errors 

and typos in your worksheets. If you have a multiple-sheet workbook, you can 

select the sheets you want to check before you start the spell checker. Also, you 

can check the spelling of just a particular group of entries by selecting the cells 

first. To check the spelling in a worksheet, follow these steps: 

Step 1:  Click the Spelling in the Proofing group of Review tab (or press F7) 

(Excel begins checking the spelling of text entries in the worksheet. When 

the program comes across an unknown word, it displays the Spelling 

dialog box. Excel suggests replacements for the unknown word shown in 

the Not in Dictionary text box with a likely replacement in the 

Suggestions list box. If that replacement is incorrect, you can scroll 

through the Suggestions list and click the correct replacement) 

Step 2:  Select one or more of the following dialog box options: 
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• Ignore Once or Ignore All: When Excel’s spell check comes across a 

word its dictionary finds suspicious but you know is viable, click the 

Ignore Once button. If you don’t want the spell checker to query you 

about this word again, click Ignore All 

• Add to Dictionary: Click this button to add the unknown word to a 

custom dictionary so that Excel won’t flag it again 

• Change: Click this button to replace the word listed in the Not in 

Dictionary text box with the selected word in the Suggestions list box 

• Change All: Click this button to change all occurrences of this 

misspelled word in the worksheet to the selected word in the 

Suggestions list box 

• AutoCorrect: Click this button to have Excel automatically correct this 

spelling error with the selected suggestion in the Suggestions list box 

(by adding the misspelling and suggestion to the AutoCorrect dialog 

box) 

Step 3:  Click OK when the spell check is complete 

 

 
 

1.40 AUTOCORRECT 

You can use the AutoCorrect feature to correct typos, capitalization errors, and 

misspelled words, as well as automatically insert symbols and other pieces of text. 

By default, AutoCorrect uses a standard list of typical misspellings and symbols, 

but you can modify the entries in this list. To modify the entries in this list you 

can open the AutoCorrect dialog box using following steps:  

Step 1:  Click Office button then click Excel Options 

Step 2:  Click Proofing and then click AutoCorrect Options 

Step 3:  Modify entries as required 
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1.41 TRACK CHANGES 

You can use change tracking to log details about workbook changes every time 

that you save a workbook. This change history can help you identify any changes 

that were made to the data in the workbook, and you can then accept or reject 

those changes. Change tracking is especially useful when several users edit a 

workbook. It is also useful when you submit a workbook to reviewers for 

comments, and then want to merge the input that you receive into one copy of that 

workbook, incorporating the changes and comments that you want to keep. 

 

When you turn on the Track Changes feature, every cell you edit will 

be highlighted with a unique border and indicator. Selecting a marked cell will 

show the details of the change. This allows you and other reviewers to see what's 

been changed before accepting the revisions permanently. To turn on change 

tracking for a workbook use following steps: 

Step 1:  Click Share Workbook, in the Review tab, of the Changes group 

Step 2:  On the Editing tab, select the Allow changes by more than one user at 

the same time check box 

Step 3:  Click the Advanced tab 

Step 4:  Under Track changes, click Keep change history for and, in 

the days box, type the number of days of change history that you want to 

keep 

Step 5:  Click Ok and, then to save the workbook, click Ok 
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1.42 ACCEPT AND REJECT CHANGES 

To accept and reject changes use following steps: 

Step 1:  On the Review tab, in the Changes group, click Track Changes, and 

then click Accept or Reject Changes 
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Step 2:  If prompted to save the workbook, click Ok 

Step 3:  In the Select Changes to Accept or Reject dialog box, choose 

appropriate options 

Step 4:  Click Ok, and then review the information about each change in 

the Accept or Reject Changes dialog box 

Step 5:  To accept or reject each change, click Accept or Reject 

Step 6:  If prompted to select a value for a cell, click the value that you want, and 

then click Accept 

 

     
 

 
 

1.43 COMMENTS 

Sometimes you may want to add a comment to provide feedback instead of 

editing the contents of a cell. Using comments can help you make a worksheet 

easier to understand by providing additional context for the data it contains. For 

example, you can use a comment as a note that provides information about data in 

an individual cell. You can also add a comment to a column heading to provide 

guidance on data that a user should enter. When a cell has a comment, a red 

indicator appears in the corner of the cell. When you rest the pointer on the cell, 

the comment appears. To add a comment to a cell use following steps: 

Step 1:  Select the cell that you want to add a comment to 

Step 2:  Click New Comment in the Comments group of the Review tab 

Step 3:  In the body of the comment, type the comment text 
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Step 4:  Click outside the comment box, the comment box disappears, but the 

comment indicator remains, to keep the comment visible, do the 

following: 

a. Select the cell 

b. Click Show/Hide Comment in the Comments group of 

the Review tab, (you can also right-click the cell that contains the 

comment, and then click Show/Hide Comments) 

 

      
 

 

 
 

 

IMPORTANT POINTS: 

• Excel is a spreadsheet application developed by Microsoft. 

• A spreadsheet is basically a matrix of rows and columns. 

• Word is first and foremost a word processor, while Excel is primarily for 

numeric calculations. 

• The primary objective of Excel is to perform basic and complex 

mathematical calculations. 

• An Excel file is a workbook that can hold one or more worksheets. 

• An Excel worksheet is a single spreadsheet that contains matrix of rows 

(designated by numbers) and columns (designated by letters). 
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• Sorting is a common spreadsheet task that allows you to easily reorder 

your data. 

• You filter data to displays only the rows that meet criteria that you specify 

and hides rows that you do not want displayed. 

• A header is a section of information that is printed above the body of the 

document, and a footer is a section of information that is printed below the 

body of the document. 

• You can print a range of pages, by using appropriate options in Print 

Range section of Print dialog box. 

• There are three types of data you enter in Excel: text, value (number), or 

formula.  

• Excel autofills dates, months, and other established patterns of non-

numerical data. 

• Excel’s Find and Replace feature is a very powerful tool that allows you to 

rapidly change the content of your worksheets. 

• Use Find and Replace to locate and optionally replace text or values in a 

worksheet. 

• To move to a specific cell of the worksheet, you can use the Go 

To command. 

• Splitting or freezing panes allow you to hold sections of a worksheet in 

place so they are visible at all times whilst scrolling through the 

worksheet. 

 

 

Practice Questions 

 

Objective type questions: 

Q1. A feature that displays only the data in column(s) according to specified 

criteria  

a. Formula 

b. Sorting 

c. Filtering 

d. Pivot 

 

Q2. The process of arranging the items of a column in some sequence or order is 

known as:  

a. Arranging 

b. Autofill 

c. Sorting 

d. Filtering 
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Q3. How many sheets are there, by default, when we create a new Excel file?  

a. 1 

b. 3 

c. 5 

d. 10 

 

Q4. Which of the following is not true regarding Conditional Formatting? 

a. You can add more than one condition to check 

b. You can set condition to look for Bold and apply Italics on them 

c. You can apply Font, border and pattern formats that meets the specified 

conditions 

d. You can delete any condition from Conditional Formatting dialog box if it 

is not required 

 

Q5. One cell format can be copied to another cell by using? 

a. Format Painter 

b. Format Setting 

c. Format Showing 

d. Format Checking 

 

Q6. Which symbol must all formula begin with? 

a. = 

b. + 

c. ( 

d. @ 

 

Q7. Which key do you press to check spelling? 

a. F3 

b. F5 

c. F7 

d. F9 

 

Very short answer type questions: 

Q1. Does MS word have advanced formatting facilities? 

Q2. By default, Excel provides how many worksheets in a workbook? 

Q3. Which command is use to save the workbook?  

Q4. Navigation buttons are presented in the ……… corner of the Excel 

workbook. 

Q5. Headers and footers are only displayed in …………. view and on the printed 

pages. 
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Q6. In excel, text entries and values are aligned to which side of the cell?  

Q7. Which command is use to display the Go To dialog box 

Q8. Which button is use to check the spelling of text entries in the worksheet? 

Q9. Why do you hide rows/columns in Excel? 

 

Short answer type questions: 

Q1. What is Microsoft Excel? 

Q2. Compare MS Word with MS Excel. 

Q3. Define worksheet and workbooks. 

Q4. What do you mean by labeling in Excel? 

Q5. How you can add a new sheet in Excel? 

Q6. What are the Navigation keys in MS Excel? 

Q7. Discuss merge and split in Excel. 

Q8. Explain the steps for creating Header and Footer in Excel. 

Q9. What do you mean by sorting? Write down steps for sorting in Excel. 

Q10. What is the benefit of using formula in Excel? 

Q11. Write short note on Header and Footer. 

Q12. What is 'Go to' command? 

 

Essay type questions: 

Q1. Explain information entering into Excel in detail. 

Q2. What is track changes? Write down steps to turn on change tracking for a 

workbook.  

Q3. What is the use of Find and Replace feature? Explain steps to perform Find 

and Replace operation? 

Q4. Explain steps to insert cells, rows and columns in worksheet. 

Q5. How you can set margins for headers and footers? 

Q6. Explain filter and sort operation in details. 

Q7. What is the difference between function and formula in Excel? 

Q8. Explain locking rows and columns by spltting panes and freezing panes. 

 

Answers key for objective questions 

 

 

Q1: c 

Q2: c 

Q3: b 

Q4: b 

Q5: a 

Q6: a 

Q7: c 


